Ram Rebel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I have owned a 2015 Ram Rebel for about 3 months. 4000 miles and have had to put new axle in it. Started making a thumping noise and they found bad axle. At 35 miles the throttle stopped working. Hopefully this will be final issues for a while.
Upgrades so far are flowmaster super 40, Airraid cold air intake, and westin 4" nerf bars.
 

·
Registered
Joined
·
660 Posts
It would be definitely be good to hear which axle and whether it was heat-treated (if it was a rear axle). Details! Cough 'em up, Tucker73! :)
 

·
Registered
Joined
·
462 Posts
Sorry to hear about the issues you've been having. How was service at the dealer during the times you went to get those issues resolved?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
Yes sorry guess it was recall I went on a trip from Texas where I bought the truck. Throttle was bad plug. Once back on road from Houston I started to here a thumping noise, it was louder when I got to Illinois and thought it was upfront and so did dealership. They took out front shafts and tech found it by doing that and riding in bed of truck lol! At time truck had 2900 miles and it took 3 weeks because axles at time was -17 in country. So I called Ram and complained, long story short got an axle and truck is fine now. Dealership also found front right wheel bearing bad WTF?
Thanks for a great Forum! My lights would flicker as well and after reading about fuses on here found mine to all be no seated in fuse box! All good now!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
I will look at paperwork from dealership when I get home tomorrow night. I can't remember which side it was on rear axle, I do remember tech telling me it was pretty chewed up! I had them make a note of it in case I get a leak or problems down the road with rear dif.
 
1 - 9 of 9 Posts
Top