Ram Rebel Modifications and Accessories - Page 8 - Ram Rebel Forum
 19Likes
Reply
 
LinkBack Thread Tools
post #71 of 72 Old 06-22-2019, 07:51 AM
Junior Member
 
dlett's Avatar
 
Join Date: Jun 2019
Location: Charlotte, NC
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
37's on a 4 Inch Lift Works!

Quote:
Originally Posted by TheGreatRam View Post
Anyone going to try installing a set of 37″ tires with the lift kit?
@TheGreatRam - I added a 4" BDS lift and 37" tires. No rubbing or trimming needed. Zero offset.

On another note, I have been trying to register for this site for 2 weeks and keep getting a message that I am a spammer. Does anyone know what I could do to fix that and register. I have quite a few mods that I would like to share with the community.
dlett is offline  
post #72 of 72 Old 06-22-2019, 07:56 AM
Junior Member
 
dlett's Avatar
 
Join Date: Jun 2019
Location: Charlotte, NC
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
Never mind the other note. For some reason I was able to finally register by adding a reply and going through the registration process that way.
dlett is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ram Rebel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome